服务热线: 0371-65995777

【安全预警】Apache Spark 远程代码执行漏洞(CVE-2020-9480)

文章来源 : 大数据IDC      发布时间 : 2020/6/29

一、概要

近日大数据IDC技术监测到Apache Spark官方发布安全公告,披露在Apache Spark <= 2.4.5的版本中存在一处远程代码执行漏洞(CVE-2020-9480)。由于Spark的认证机制存在缺陷,导致共享密钥认证失效。攻击者利用漏洞可在未授权的情况下,远程发送特制RPC启动Spark集群上的应用程序资源,可以用它在主机上执行shell命令。

大数据IDC提醒使用Apache Spark的用户及时安排自检并做好安全加固。

详情请参考链接:

https://spark.apache.org/security.html

二、威胁级别

威胁级别:【严重】

(说明:威胁级别共四级:一般、重要、严重、紧急)

三、漏洞影响范围

影响版本:

Apache Spark < = 2.4.5

安全版本:

Apache Spark  2.4.6或3.0.0

四、漏洞处置

目前,官方已在新版本中修复了该漏洞,请受影响的用户升级到安全版本。

下载地址:https://github.com/apache/spark/releases

注:修复漏洞前请将资料备份,并进行充分测试。

上一条:【安全预警】微软6月份月度安全漏洞预警 下一条:【安全预警】Apache Tomcat HTTP/2拒绝服务漏洞(CVE-2020-11996)