服务热线: 0371-65995777
   
 
关于Apache Solr反序列化远程代码执行漏洞(CVE-2019-0192)安全预警
文章来源 :大数据通信      发布时间 :2019/3/8 16:31:11
 

一、概要

近日,Apache官方发布一则关于开源企业级搜索平台Solr 的安全公告,当中披露了一个严重等级的远程反序列化代码执行漏洞(CVE-2019-0192)。由于SolrConfigAPI允许通过HTTP POST请求配置SolrJMX Server端。攻击者可以利用其特性将其指向恶意的RMI / LDAP服务,通过javaObjectInputStream响应任意对象,从而触发对象在Solr端的反序列化远程代码执行。

大数据通信提醒各位租户及时安排自检并做好安全加固。

利用漏洞:CVE-2019-0192

参考链接:

https://issues.apache.org/jira/browse/SOLR-13301?spm=a2c4g.11174386.n2.4.3cc21051uLaml0

二、威胁级别

威胁级别:【严重】

(说明:威胁级别共四级:一般、重要、严重、紧急。)

三、影响范围

Apache Solr < 7.0.0

四、修复方案

·  升级到Apache Solr 7.0或更高版本。

·  如果不使用ConfigAPI,请通过系统属性disable.configEdit = true运行Solr来禁用ConfigAPI

·  如果升级或禁用Config API不可行,请应用SOLR-13301.patch并重新编译Solr

·  通过修改网络访问配置,设置只允许受信任的流量进出运行Solr的主机。

注意:修复漏洞前请将资料备份,并进行充分测试。